• To access Klaxoon, you need a recently updated browser. Here are the supported versions:

      • Google Chrome
      Version 80 or higher
      • Mozilla Firefox
      Version 78 or higher
      • Microsoft Edge
      Version 80 or higher
      • Apple Safari
      Version 13.1 or higher
      • Internet Explorer
      Note that Internet Explorer 11 is no longer supported by Microsoft and is obsolete. For more information, click here.

      Browser configuration required: 

      You must enable Javascript and accept Cookies.